Home > SI5 Documentation > User Guide > AutoCAD Interface > Right Click Menu

Right Click Menu

Right-Click Options for AutoCAD

In addition to the Add Product/Package option described above in this section of the guide, there are additional right-click options available to you.  Your right-click menus will vary depending on whether you right-click a Product in the PDM or if you right-click in the Drawing Area.

When you right click selected Product(s) or Package(s) in the PDM, the right click menu displays as shown below:

File:AutoCAD_Interface/Right_Click_Menu/image001.png 

Most of these options are detailed here, Right-Click Options. The AutoCAD Project Interface specific options are discussed below.

notes_50Some of these options will apply across multiple Products, some only for the primary selected Product.  A selected Product is indicated by a gray row color, and the primary selected Product is indicated with an arrow in the PDM:

File:AutoCAD_Interface/Right_Click_Menu/image003.png

Right-Click->Replace Product

This function is detailed here.  In AutoCAD, there is an additional option on the form, "Maintain Block(s)", allowing you to keep the blocks on the existing sheets for replaced products.

maintain blocks.jpg

 

Right-Click->Find Block

This works for the primary selected Product in the PDM.  This option will find and select the block for that product on the drawing sheet.

Right-Click->Dock->Left/Right/Top/Bottom/Float

This option applies the entire PDM and will dock or float the window based on your choice.

Right-Clicking on Blocks

When you right-click in the drawing area on a drawing sheet, the right click menu displays as shown below:

File:AutoCAD_Interface/Right_Click_Menu/image004.png

Right-Click->D-Tools->Find in Project DataMatrix

This option works for only one selected Block at a time.  This will find and select the Product in the PDM.

Right-Click->D-Tools Block->Block->Insert Alternate View

This will open the Insert Alternate Block form which allows you to choose any block from the Block Tree to represent an alternate view of the Product.  The blocks will have the same Component ID as each other.  You can choose any block from any drawing for this second alternate view.

Note: If used with a Wire and Cable block on a Schematic sheet, the alternate view block that is created will not have connection functionality, i.e. connections made with this block will not pass data to our Installation reports.

File:AutoCAD_Interface/Right_Click_Menu/image005.png

Right-Click->D-Tools->Block->Change Block

If the default block that displays on a drawing sheet is not the block you want, you can change the block to any block from any drawing.

File:AutoCAD_Interface/Right_Click_Menu/image006.png

There is a “Save as default visualization for this view” option at the bottom of the form:

File:AutoCAD_Interface/Right_Click_Menu/image007.png

This will fill in the fields on the Visualizations tab of the Product Properties:

File:AutoCAD_Interface/Right_Click_Menu/image008.jpg

Right-Click->D-Tools->Block->Link To D-Tools

This option allows you to link a block that you have created to a product in your SI5 database.  Once you create a block and link it to a Product in SI5, you may want to add the block you created to a drawing so that you can use it in future Projects.

 Example:

1)    Select the block you want to link then Right-Click->D-Tools-> Block->Link To D-Tools. The Add Product form opens.

Note: If you do not see the D-Tools menu, use the command DTLINKTODTOOLS

File:AutoCAD_Interface/Right_Click_Menu/image009.jpg

2)    Select the Product that you want to link this block to in the Add Product form then click [Add to Project]:

File:AutoCAD_Interface/Right_Click_Menu/image010.jpg

3)    The block is now linked to the Product that you selected and the Product has been added to the PDM.

You can add attributes to your custom block if you wish, e.g. Model, ComponentID, etc.

4)    Select the block and then in the command line type: bedit

The Edit Block Definition form will open:

File:AutoCAD_Interface/Right_Click_Menu/image011.png

5)    Select the block you created from the list and click [OK].  The block will now show in the Block Editor screen:

File:AutoCAD_Interface/Right_Click_Menu/image012.jpg

6) In the command line type: attdef

The Attribute Definition form will open. 

File:AutoCAD_Interface/Right_Click_Menu/image013.png

7)    Type “Manufacturer” in the Tag field then click [OK]

8)    The attribute will be displayed on the cursor.  Pick a spot you want this attribute and left mouse click to place it page:

File:AutoCAD_Interface/Right_Click_Menu/image014.png

9)    In the command line type: copy

A copy of the attribute will be made, left click where you want to place the attribute.

10) Repeat step nine two more times until you have a total of four “Manufacturer” attributes on the page:

File:AutoCAD_Interface/Right_Click_Menu/image015.png

10) In the command line type:  ddedit

Select one of the three copied attributes and change the tag for each as shown below.  You will need to complete step ten a total of three times.

File:AutoCAD_Interface/Right_Click_Menu/image016.png

File:AutoCAD_Interface/Right_Click_Menu/image017.png

File:AutoCAD_Interface/Right_Click_Menu/image018.png

For the Category attribute, add an appropriate Category name to the Default field.

When finished, the block should look this:

File:AutoCAD_Interface/Right_Click_Menu/image019.png

11) Use the commands bsave and bclose to close the block editor.

12) In the command line type: saveas

The Save Drawing As form will open.  Type in a filename and then choose the path below in the “Save in:” dropdown. In this example I named the drawing: Custom Plates.dwg

Win7/Vista:  C:\ProgramData\D-Tools\SI5\Visualizations\Blocks

XP:  C:\Documents and Settings\All Users\Application Data\D-Tools\SI5\Visualizations\Blocks

File:AutoCAD_Interface/Right_Click_Menu/image020.jpg

 

13) Click [Save]

14) When you open an AutoCAD file for an SI5 Project, the drawing you created will display in the Custom section of the Block Tree:

File:AutoCAD_Interface/Right_Click_Menu/image021.png

notes_50The block is a one-to-many relationship with  Products in the SI5 database.


Right-Click->D-Tools->Block->Change Color

This function does not work for SI 5 Schematic blocks.  This will open the AutoCAD Select Color form:

File:AutoCAD_Interface/Right_Click_Menu/image022.png

Right-Click->D-Tools->Block->Change Layer

This function does not work for SI 5 Schematic blocks.  This will open the D-Tools Change to Layer form.  All SI 5 blocks are assigned to layer “0” by default.  Use AutoCAD functions to create your own layers.

File:AutoCAD_Interface/Right_Click_Menu/image023.png

Right-Click->D-Tools->Wire Options->Show ComponentID

This only applies to schematic sheet types and only to the Schematic block in the Wire and Cable drawing:

File:AutoCAD_Interface/Right_Click_Menu/image024.png

This option will open a dialog that allows you to choose where the Component ID text label displays on the block:

File:AutoCAD_Interface/Right_Click_Menu/image025.png

You can do this for just the selected blocks on the sheet or all of the blocks:

File:AutoCAD_Interface/Right_Click_Menu/image026.png

 

 

Last modified
15:28, 26 Nov 2013

Tags

Classifications

This page has no classifications.