Home > SI5 Documentation > User Guide > Visio Interface > Tips Tricks > Modify SI5 Shapes

Modify SI5 Shapes

Modifying Existing SI 5 Shapes

You can either modify shapes directly in the stencil they already exist in or you can create a new stencil.  Either way, always copy and paste the existing shape you wish to modify in case you mess up.  In this example I will create both the input and output units for the Niles ES1 for use on a plan page type in Visio based off an existing SI 5 plate shape.

  1. Launch an SI 5 Visio project file and select File->Shapes->New Stencil (US Units).  The stencil will display in the Shapes Window.

7413844_image002

  1. In the Stencil Tree right-click the Plates stencil and select “Display Docked Stencil”.  The stencil will display in the Shapes window.
  2. Right click the Stencil header in the shapes window and select “Edit Stencil”.

http://content.ll-0.com/d-tools/word_images/7413844_image004.jpg?i=071708133952

  1. Copy the Media Plate shape from the Plates stencil and paste into the stencil created in Step 1.
  2. Rename the Shape to “ES1 Input Plate”

http://content.ll-0.com/d-tools/word_images/7413844_image006.jpg?i=071708133952

  1. Double-click the shape to open it.

http://content.ll-0.com/d-tools/word_images/7413844_image008.jpg?i=071708133952

  1. Click on the shape to select it (a dotted green border surrounds the shape when selected) and then select Window->Show ShapeSheet.

http://content.ll-0.com/d-tools/word_images/7413844_image010.jpg?i=071708133952

  1. In the ShapeSheet, remove the text “Wall Plate” text from the Prop.Type line Value column in the Custom Properties section so that only double quotes are in the field

http://content.ll-0.com/d-tools/word_images/7413844_image012.jpg?i=071708133952

 

 

  1. Next change the value of the LockGroup field in the Protection section from “1” to “0” then close the ShapeSheet window.

http://content.ll-0.com/d-tools/word_images/7413844_image014.jpg?i=071708133952

  1. With the shape still selected (dotted green border), select Edit->Open Multi Media Wallplate

http://content.ll-0.com/d-tools/word_images/7413844_image016.jpg?i=071708133952

  1. Make any changes to the shape that want.  I deleted the existing connector shapes and then drew some new shapes using the Drawing Toolbar.  I used Visio functions like Format->Fill and Format->Line

http://content.ll-0.com/d-tools/word_images/7413844_image018.jpg?i=071708133952

  1. Close and save the shape windows.
  2. Within the stencil, copy and paste the shape you just modified and rename to “ES1 Output Plate” and then modify as desired.
  3. Right-click the stencil and select Properties:

http://content.ll-0.com/d-tools/word_images/7413844_image020.jpg?i=071708133952

  1. Type an appropriate name in the Title field and then close the Properties form

http://content.ll-0.com/d-tools/word_images/7413844_image022.jpg?i=071708133952

  1. Click the Save button in the docked stencil title bar and name and save the file to the following folder: C:Documents and SettingsAll UsersApplication DataD-ToolsSI5VisualizationsStencils folder (Vista path is C:ProgramDataD-ToolsSI5 VisualizationsStencils).

http://content.ll-0.com/d-tools/word_images/7413844_image024.jpg?i=071708133952

  1. The stencil you created will display in the Stencil Tree once you click the refresh button

http://content.ll-0.com/d-tools/word_images/7413844_image026.jpg?i=071708133952

When you drag the shapes to a drawing page you will be prompted to pick a product from your database to add to the Project DataMatrix (PDM).

http://content.ll-0.com/d-tools/word_images/7413844_image028.jpg?i=071708133952

Make sure you make backups of any stencil that you create in case you ever uninstall and re-install SI 5.  In order to share with other SI 5 users, they will need to copy the stencil you created into their : C:Documents and SettingsAll UsersApplication DataD-ToolsSI5VisualizationsStencils folder on their machine (Vista path is C:ProgramDataD-ToolsSI5 VisualizationsStencils).

Note: If you can’t find the folder referenced above, that is because some of the folders are hidden.  To change the settings on your machine to show hidden folders, open My Computer and then select Tools->Folder Options.  Click the View tab and check the “Show hidden files…” radio button.  While you are here, you may want to uncheck the “Hide extensions for…” option.

http://content.ll-0.com/d-tools/word_images/7413844_image030.jpg?i=071708133952

 

 

You must to post a comment.
Last modified
15:09, 26 Nov 2013

Tags

This page has no custom tags.

Classifications

This page has no classifications.