Home > SI5 Documentation > User Guide > Pre-Implementation > Software Requirements

Software Requirements

Software Requirements and Compatibility

Note: as with all of the documentation here on the Diki, this information pertains to our latest release of SI5.5 which is Service Pack 3 (SP3), build 5.5.860.0.

This page discusses the necessary software needed in order to install and work with SI5.5 as well as optional third-party software compatibility.

Operating System 

  • Microsoft Windows XP with SP2 or later                                 
  • Microsoft Windows Vista 
  • Microsoft Windows 7 
  • Microsoft Server 2003 
  • Microsoft Server 2005 
  • Microsoft Server 2008*

 

* Do not use the pre-installed SQL Server 2008 instances that come in SBS 2011 - during your server configuration, allow the SQL 2005 instance from our installer to be installed.  In the SQL 2008 instance pre-installed on SBS 2011, direct SQL connections are blocked and some functionality in SI5 require direct connections.

Note: Will work with either 32-bit or 64-bit operating systems running on a PC.  However, there are limitations to what 64-bit applications SI5 is compatible with, see below.

Required Software 

  • Microsoft .NET Framework 3.5 SP1*
  • Windows Installer 3.1*
  • SQL Server 3.5 Compact Edition* 

*Will install automatically. Internet connection required.   

SI5.5 Server Requirements and Compatibility 

  • SQL Server 2005 Express Edition (included on CD/Install) 
  • SQL Server 2005 (compatible, not required) 
  • SQL Server 2008 (compatible, not required) 

 

Note: We highly recommend that you use SQL Server 2005 Express.  Using your own instances of SQL are tough to troubleshoot and you will have a much smoother implementation if you use our default install of SQL Server 2005 express.  If you do use your own instance of SQL you must verify that remote connections are enabled for both "TCP/IP" and "Named Pipes" as these are not enabled by default in SQL 2008. See here for instructions on what changes you will need to make when using SQL 2008.

Compatibility 

System Integrator 5.5 works with the following applications:

  • Microsoft Visio 2003, 2007, & 2010, 32-bit versions only* (see here for differences in Visio 2010)
  • Microsoft Office 2007 & 2010, 32-bit versions only* (we are compatible with Outlook 2010 but our Excel Reports are NOT compatible with Excel 2010)
  • Microsoft Project 2003, 2007, & 2010 32-bit versions only*
  • AutoCAD  2006-2012** ***
  • QuickBooks Pro/Premier  (US 2006-2012, CAN 2006-2012, UK 2005, 2008, & 2010) See Known Issues
  • QuickBooks Enterprise (US 7-12) See Known Issues

 

* If you have the 64-bit version of Office installed, you will NOT be able to install the 32-bit version of Visio.  You must have the 32-bit version of Office if you wish to install the 32-bit version of Visio.

** Only 32-bit Full versions of AutoCAD (LT will NOT work). If you are running a 64-bit OS, you must install a 32-bit version of AutoCAD to have functionality with SI5. See here for a potential solution to get the 32-bit version of AutoCAD installed on a 64-bit machine.

*** In order to work with AutoCAD 2012 or with one of the AutoCAD verticals (Mechanical, Electrical, etc.) see here for instructions.

Networking

500 kbps bi-directional (10+ Mbps is recommended)
Windows file sharing capability

 

See Hardware Recomendations

Edit section

 

 

Last modified
12:42, 26 Nov 2013

Tags

This page has no custom tags.

Classifications

This page has no classifications.