Home > SI 2015 Documentation > User Guide > Projects > Visio Interface > Visio Shapes > Plan Shapes > Editing Symbol Legend Shapes

Editing Symbol Legend Shapes

Table of contents

Details

 

You can edit the Symbol Legend shapes for any of the Plan Shape stencils in Visio by following these instructions.

 

By design the symbol legend has been converted from Visio shapes to file type WMF vectors and text. This was done so the legend could be easily resized and work on any page scale.  You can’t do that with grouped Visio shapes and text. This makes for a nice, clean, lightweight shape but it also means that you cannot edit this shape.

Steps

 

  1. Open a Visio file from SI 2015 and click the Plan View tab or change the Drawing Scale of whatever page you are on to be 1/4" = 1'.
  2. Make sure that you have the Developer tab viewable. If you have done this previously in Visio, click File->Options.
  3. In the Visio Options window, click the Customize Ribbon option and then click the checkbox next to Developer, then click [OK]:

 

visio_options.png

 

  1. In the D-Tools SI 2015 shapes window, right-click the stencil you wish to edit and choose Open Stencil. In this example the "Sensor Floor Plan Symbols" stencil was used from the SIA section.

 

 

Note: Notice that there are two Symbol Legend shapes in the stencil, "Symbol Legend" and "Symbol Legend Editable". This first method will focus on the "Symbol Legend Editable" shape.

 

The Stencil will open in the Shapes window:

 

 

  1. Right-click on the stencil name in the Shapes window and select Edit Stencil:

 

 

  1. Make a copy of the Symbol Legend and Symbol Legend Editable shape by doing a Ctrl + drag in the stencil, or copy and paste. They will be named automatically with a .## (random number) after the name. These are your backup shapes in case you mess up.
  2. Double-click the original "Symbol Legend Editable" shape to open for edit, it will open in a new window:

 

opened_shape.png

 

  1. Right click on the Symbol Legend shape in the new window and choose Group->Open Group. This will open the shape in a new window.  The new window will allow you to edit the individual shapes and text in the master shape.

 

Note: DO NOT Ungroup the shape. Use the "Open Group" command as instructed.

 

open_group.png

 

  1. Make your edits. To add more rows to the symbol legend grid click the bottom of each column and drag down. You will see it automatically add rows.  Do that for all columns needed.

 

drag_columns.png

 

 

Note: If you want to add a new shape/symbol to the Symbol Legend Editable shape you can drag them over from any other D-Tools stencil. To do this you may need to click the View tab and then the [Arrange All] button:

 

 

arrange_all_view_option.png

 

If you do add any existing SI 2015 shapes to your custom legend (vs. adding/drawing your own shapes) you will need to remove the coding from the shape (the coding that makes it smart and linked ot an SI 2015 Product). The easiest way to do this is to select the added shape and then from the Developers tab click Operations->Combine:

 

combine_command.png

 

  1. When done, close the opened group window, then close the grouped window. You will be prompted to save the shape, choose [Yes]:

 

 

Now you will want to update the Symbol Legend shape with a .wmf (Windows Metafile) of the Symbol Legend Editable shape you just modified.

 

  1. Dra.g your modified Symbol Legend Editable shape over to the Plan view page in Visio.
  2. With the shape selected, click File->Save as and choose to save as a .wff file to a temporary location:

 

save_as_wmf.png

 

  1. In your docked stencil, double-click the Symbol Legend shape to open it. It will open in its own window. Select the shape:

 

selected_shape.png

 

  1. Click [Delete] on your keyboard. You will now have a "blank" shape:

 

blank_shape.png

 

  1. Click the Insert tab then browse to the .wmf file you saved earlier:

 

 

  1. Your .wmf file will display. Close the window and click [Yes] when prompted to update the shape:

 

 

  1. Drag the Symbol Legend shape over to the Plan View page in Visio to test.
  2. When done, click the Save button in the corner of the opened stencil:

 

 

  1. Right-click on the stencil name and choose Edit Stencil to take the stencil out of edit mode:

 

Last modified
20:14, 9 Mar 2015

Tags

This page has no custom tags.

Classifications

This page has no classifications.